Back to overview
Temporary slowdown resolved
Apr 3, 2025 at 12:11pm UTC
Affected services
Main Dashboard
Resolved
Apr 3, 2025 at 12:11pm UTC
Dashboard was very slow for a few minutes - performance has recovered
Affected services
Resolved
Apr 3, 2025 at 12:11pm UTC
Dashboard was very slow for a few minutes - performance has recovered
Affected services